Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted Mar 14, 2016 - 10:09 EDT
Identified
We are currently experiencing an unscheduled service interruption. Customers have reported being unable to access drafts view in Safari. Our team has identified the cause and is working to resolve. If possible, another browser should be used to access this view. We appreciate your patience.
Posted Mar 14, 2016 - 09:04 EDT