DDOS attack
Incident Report for AWeber
Resolved
All AWeber services are back up and running normally. We appreciate your patience as we've mitigated this massive DDoS attack.

Email broadcasts and follow-ups will take a few hours to catch up as they were backlogged during the downtime. Also, due to caching reasons, changes to JavaScript web signup forms within the Control Panel will take up to 24 hours to take effect on your websites. We are working on resolving this so changes will take affect in real-time moving forward.

Please know that this attack impacted access to our website, and no customer or subscriber information was compromised. We continue to monitor for any future issues.
Posted about 4 years ago. Mar 01, 2014 - 00:22 EST
Update
We continue work as quickly as possible to mitigate this afternoon's DDoS attack. We apologize for the frustration this has caused, and appreciate your patience.
Posted about 4 years ago. Feb 28, 2014 - 16:00 EST
Update
We are experiencing yet another DDoS attack, causing intermittent access to accounts. Fortunately, we have protections in place and our engineers are working to resolve it right now.
Posted about 4 years ago. Feb 28, 2014 - 13:21 EST
Update
Due to caching reasons, changes to JavaScript web signup forms from the Control Panel will take up to 24 hours to take effect on your website. We are working on resolving this as quickly as possible.
Posted about 4 years ago. Feb 28, 2014 - 11:15 EST
Update
The order page is now up and running. We continue to work on resolving the issue with confirmation emails not going out for subscriber imports and @listname submissions. Thanks for your patience.
Posted about 4 years ago. Feb 27, 2014 - 15:38 EST
Update
We are experiencing an issue with confirmation emails not going out for subscriber imports and @listname submissions, as well as our order page. Our engineers are working on resolving these right now and hope to have them resolved soon. In the meantime, if you wish to create an AWeber account, you can call our Customer Solutions team at 877-293-2371.
Posted about 4 years ago. Feb 27, 2014 - 13:36 EST
Update
Nearly all customers are now able to access their accounts. If you're still having trouble accessing yours or seeing your signup forms appear on your website, it's likely that your DNS is still updating. Once this occurs, you should be able to access your account and your forms should appear on your site.
Posted about 4 years ago. Feb 26, 2014 - 22:34 EST
Update
To our valued and loyal customers,

On behalf of the entire AWeber team, I want to deeply apologize for the service interruptions that you've experienced over the last 48 hours. We understand how much you rely on our service to help run and grow your business and the frustration this has likely caused. I want to explain what happened and what we're doing to lessen the likelihood that it will happen again.

Beginning Monday, we experienced a repetitive Distributed Denial of Service (DDoS) attack which left our service unavailable. For those unfamiliar with the term, a DDoS attack is when an attacker floods a site with so much traffic it is unable to respond to legitimate requests. While we already had systems in place to deal with these types of attacks, the nature and severity of this attack was on a massive scale. It is important to know that absolutely no customer data or information was compromised.

In the last 48 hours, we have devoted all available resources and worked around the clock to get our network back online and put new and stronger mitigation systems in place. At this time, 95+ percent of our customers have full access to our service. Our remaining customers may have partial or unavailable service as ISPs update their DNS systems. To be clear, our website is 100 percent back online, but some customers may have trouble accessing it over the next several hours.

Moving forward, we remain fully committed to providing you with the highest level of service possible. While attacks like this could happen to any website, no one ever wants it to happen to them. We've already learned from this incident and will continue to learn, so that we can make our service even stronger.

Thank you for your continued support.

Tom Kulzer
CEO & Founder
AWeber Communications, Inc.
Posted about 4 years ago. Feb 26, 2014 - 16:55 EST
Update
All sign-up forms have been restored and all JavaScript snippets and hosted links should be working as designed. All new subscribers to your site should not have any issues. Any changes made to forms will take 24 hours to populate on your site or the hosted link. This is temporary. It may take a few days for us to continue making updates before form changes are reflected in real-time. Thank you again for your patience.
Posted about 4 years ago. Feb 26, 2014 - 16:47 EST
Monitoring
Newsletter broadcast and follow up sending has been re-enabled about 60 minutes ago. DNS has propagated over 95%, however some visitors may still receive timeouts until their ISP DNS caching systems update. We are continuing to monitor for any ongoing issues, but for right now all visitors with updated DNS should be seeing all services at 100%.
Posted about 4 years ago. Feb 26, 2014 - 06:40 EST
Update
Broadcast and follow-up messages are being held in queue until our newly configured IP addresses have reached a significant number of DNS servers around the globe. Once this has been accomplished, we can enable email broadcasts and follow-ups to begin distributing.
Posted about 4 years ago. Feb 26, 2014 - 04:27 EST
Update
Our engineering team has the site coming back up. New IPs were configured that will need to be distributed across the Internet. For many customers, access to accounts is available, web forms are being displayed, click tracking links are redirecting properly, and new subscribers are being accepted. If you are not able to access the site currently, it may take up to a few hours for the changes to reach your ISP. Thank you again for your patience as we mitigate this massive DDoS attack.
Posted about 4 years ago. Feb 26, 2014 - 00:55 EST
Update
Our engineering team continues to work this issue thru the night.
Posted about 4 years ago. Feb 25, 2014 - 22:27 EST
Update
We have been diligently working with our upstream provider Windstream to resolve the effects of the DDoS attack we experienced earlier this afternoon. We do not yet have an estimate on when this incident will be resolved. Again, we apologize for the inconvenience and frustration this has caused.
Posted about 4 years ago. Feb 25, 2014 - 17:22 EST
Update
If your website is loading slowly because of the JavaScript from your AWeber form, simply add the word "defer" to the script. This will resolve the site loading issue. Example: "...script defer type..."
Posted about 4 years ago. Feb 25, 2014 - 16:01 EST
Update
We continue to work on resolving the effects of this DDoS attack. We appreciate your patience.
Posted about 4 years ago. Feb 25, 2014 - 15:27 EST
Identified
We continue to work to resolve the DDoS attack. We sincerely apologize for the inconvenience and appreciate your patience.
Posted about 4 years ago. Feb 25, 2014 - 13:49 EST
Investigating
We are experiencing a new DDOS attack similar to yesterday causing an unscheduled interruption, limiting access to our website and customer accounts. We are currently investigating and working to resolve the situation. We apologize for the inconvenience.
Posted about 4 years ago. Feb 25, 2014 - 13:09 EST