Unscheduled Interruption
Incident Report for AWeber
Resolved
This incident has been resolved. We appreciate your patience.
Posted Jan 12, 2016 - 18:18 EST
Investigating
We are experiencing an unscheduled interruption. Customers in our Campaigns Beta may experience a delay in first followup messages. Our team is investigating the cause and will provide further updates. We appreciate your patience.
Posted Jan 12, 2016 - 16:17 EST