Unscheduled Interruption
Incident Report for AWeber
Resolved
All issues loading aweber.com and logging into your AWeber account have been resolved. The issue was the result of a DNS issue caused by our domain host that has been addressed.

Delays in sending campaign and broadcast messages have also resolved.

We appreciate your patience.
Posted Apr 23, 2024 - 19:19 EDT
Identified
The issue has been identified and we are implementing a fix.
Posted Apr 23, 2024 - 18:07 EDT
Investigating
We are experiencing an unscheduled service interruption. In some regions, users will not be able to load aweber.com or log in to their AWeber account. Campaign and broadcast messages are also currently delayed.

Our team is working to resolve the issue. We will provide updates as they become available. We apologize for the inconvenience and thank you for your patience.
Posted Apr 23, 2024 - 17:53 EDT
This incident affected: Main Site, Customer Logins, and Email Sending.