Unscheduled interruption

Incident Report for AWeber

Resolved

We addressed the cause of the unscheduled interruption, which affected click tracking and caused a delay in adding new subscribers. Click tracking is now working as expected and new subscribers are being added as expected. Any new subscribers acquired during the interruption have been added as well. Thank you for your patience.
Posted Jul 28, 2025 - 09:57 EDT

Identified

We are currently experiencing an unscheduled interruption, affecting click tracking and causing a delay in adding new subscribers. New subscribers will still be captured and added once resolved. We have identified the cause and are working to resolve it. All other services are working as expected. We will provide updates as they become available. Thank you for your patience.
Posted Jul 28, 2025 - 09:35 EDT
This incident affected: Email Sending and Subscriber Sign Ups.