Unscheduled interruption

Incident Report for AWeber

Resolved

We addressed the cause of the unscheduled interruption impacting access to the subscriber management page. Customers are now able to access the subscriber management page and all services are working as expected. There was no interruption in adding new subscribers. Thank you for your patience.
Posted Aug 07, 2025 - 17:39 EDT

Investigating

We are currently experiencing an unscheduled interruption, impacting access to the subscriber management page. New subscribers will still be added and all other services are working as expected. Our team is currently working to identify the cause and resolve it. We will provide updates as they become available. We apologize for the inconvenience and thank you for your patience.
Posted Aug 07, 2025 - 17:19 EDT
This incident affected: Subscriber Sign Ups.