Unscheduled Interruption
Incident Report for AWeber
Resolved
This incident has been resolved.
Posted Dec 21, 2015 - 12:54 EST
Identified
We are currently experiencing an unscheduled interruption. Our message editor is unavailable and customers will not be able to create or edit drafts. The cause has been identified and we are working to resolve it. We appreciate your patience.
Posted Dec 21, 2015 - 12:36 EST