Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 11 months ago. Jun 17, 2016 - 15:38 EDT
Investigating
We are currently experiencing an unscheduled interruption in processing new subscriber notifications. Our team is currently investigating. We will provide updates as needed. Thank you for your patience.
Posted 11 months ago. Jun 17, 2016 - 15:25 EDT