Newsletter Archive Interruption
Incident Report for AWeber
Resolved
After further monitoring, no additional incidents with newsletter archives were discovered.
Posted Dec 23, 2014 - 08:56 EST
Update
Newsletter archives are operational. We continue to investigate the root cause of the interruption.
Posted Dec 22, 2014 - 16:55 EST
Investigating
We are experiencing an interruption limiting access to newsletter archives. All other services are working as normal at this time. We are investigating the cause and working to resolve the situation as quickly as possible. Thank you for your patience.
Posted Dec 22, 2014 - 14:50 EST