Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted May 06, 2016 - 15:01 EDT
Identified
We are currently experiencing an issue with email sending. Our team has identified the cause and is working to resolve the issue. We will provide updates when available. We appreciate your patience.
Posted May 06, 2016 - 14:30 EDT