Delay in Broadcasts
Incident Report for AWeber
Resolved
The delay has been resolved. All broadcast and follow-up messages are now going out. Thanks your patience. It may take several hours for all backlogged messages to catch up.
Posted Mar 12, 2014 - 10:36 EDT
Identified
We are experiencing an unexpected delay in broadcasts. Our engineers are working diligently to resolve it as soon as possible.
Posted Mar 12, 2014 - 09:34 EDT