Toll Free Phone Service Interruption
Incident Report for AWeber
Resolved
Our toll-free phone support is now available. Thank you for your patience while we resolved the interruption.
Posted Jan 19, 2015 - 09:46 EST
Investigating
We are currently experiencing an interruption with our toll-free phone number. Customers can still receive support by calling +1 215-825-2196 or by email or live chat. We apologize for any inconvenience.
Posted Jan 19, 2015 - 09:03 EST