Brief Site Interruption
Incident Report for AWeber
Resolved
The flood of traffic has been fully mitigated and is no longer occurring.
Posted Apr 11, 2014 - 20:22 EDT
Identified
We are currently experiencing a large flood of malicious traffic targeted at our website. You may have seen some short blips when attempting to connect, but our mitigation procedures are now fully blocking it.
Posted Apr 11, 2014 - 19:36 EDT