Intermittent Account Access & New List Creation
Incident Report for AWeber
Resolved
Account access and list creation is now working normally. Thank you for your patience and understanding.
Posted Feb 26, 2015 - 11:02 EST
Investigating
We have received reports of intermittent account access as well as the inability to create new lists within accounts. We are investigating the incidents and are working to resolve it as quickly as possible. Our apologies for the inconvenience.
Posted Feb 26, 2015 - 10:37 EST