Delay in Email Sending
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 11 months ago. Oct 19, 2016 - 20:29 EDT
Investigating
We are currently experiencing an unscheduled service interruption. At this time, customers may experience a delay in email sending. Our team is working to identify the issue and will provide updates as they become available. We appreciate your patience.
Posted 11 months ago. Oct 19, 2016 - 09:44 EDT