Unscheduled Interruption
Incident Report for AWeber
Resolved
The issue has been resolved. Thank you for your patience.
Posted Oct 16, 2015 - 19:39 EDT
Identified
We are experiencing an issue with subscriber signups. Our engineering team has identified the issue and is working to resolve it now. We appreciate your patience.
Posted Oct 16, 2015 - 17:36 EDT