Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 4 months ago. Jan 24, 2017 - 09:13 EST
Investigating
We're currently experiencing an unscheduled service interruption. At this time, new and current customers are unable to create new lists. Our team is working to identify the issue and we will provide updates as they become available. We apologize for any inconvenience.
Posted 4 months ago. Jan 24, 2017 - 08:55 EST