Intermittent Interruption
Incident Report for AWeber
Resolved
The interruption has been resolved and all services are working normally. Thank you for your patience.
Posted Mar 17, 2015 - 12:09 EDT
Investigating
We are experiencing an unscheduled interruption, affecting some customers' ability to save and send messages, as well as a delay in broadcast messages being sent. We are working to resolve it as quickly as possible and appreciate your patience through the process.
Posted Mar 17, 2015 - 10:56 EDT